Baseball for the Thinking Fan

Login | Register | Feedback

btf_logo
You are here > Home > Jim's Lab Notes > Discussion
Jim's Lab Notes
— Site News, Baseball Talk, and a Bunch of Other Stuff

Sunday, December 07, 2014

Recent Updates and Turning off Advertisements

As you may have noticed, I’ve been working on the server and making some software updates. The downtime was required so I can move forward with some of the things on my off-season to-do list. I hope the outages didn’t inconvenience you too much.

First up on my to-do list was setting things up so I could turn off advertising for those of you who generously donated to support the site in 2014. Although automating the process is still on my list, I have turned off advertising on accounts that donated at least $20 in the 2014. Since some of you don’t use the same email address, I had no way of associating your donation with your account for some of you. So, if you donated but still see ads, please drop me an email with the email address associated with your donation and the email address that you use with your BBTF account.

I apologize for not getting around to this earlier. Hopefully, you’ll be happy seeing the site load a little faster without ads for the next year. 

Thanks for your support!

Jim Furtado Posted: December 07, 2014 at 01:37 PM | 55 comment(s) Login to Bookmark
  Related News:

Reader Comments and Retorts

Go to end of page

Statements posted here are those of our readers and do not represent the BaseballThinkFactory. Names are provided by the poster and are not verified. We ask that posters follow our submission policy. Please report any inappropriate comments.

   1. Infinite Yost (Voxter) Posted: December 07, 2014 at 02:04 PM (#4856115)
Welp, this reminds me that I forgot to donate.
   2. ERROR---Jolly Old St. Nick Posted: December 07, 2014 at 02:28 PM (#4856131)
I've been getting this message for the past few days every time I've hit the Preview Your Comment tab:

Error

Something has gone wrong and this URL cannot be processed at this time.


I sure hope that this can be fixed. Everything else seems to work okay.
   3. McCoy Posted: December 07, 2014 at 02:55 PM (#4856150)
Is it just ignorance on my part or is there really no option to change the clock on BTF?
   4. Scott Ross Posted: December 07, 2014 at 04:59 PM (#4856210)
"I have turned off advertising"

God bless you, good sir. This may be the best present I get this Christmas.
   5. Mark S. is bored Posted: December 07, 2014 at 05:16 PM (#4856223)
The forums have disappeared. They don't show up and if you click on an old link to one of them, it says you're not authorized.
   6. Harveys Wallbangers Posted: December 07, 2014 at 05:38 PM (#4856238)
mark

now the forums show on the front page but you cannot access

i suspect this is being fixed
   7. Harveys Wallbangers Posted: December 07, 2014 at 05:44 PM (#4856243)
still cannot access lounge topics
   8. Harveys Wallbangers Posted: December 07, 2014 at 05:47 PM (#4856245)
cannot post to some articles. like the melvin article on positioning
   9. Harveys Wallbangers Posted: December 07, 2014 at 06:05 PM (#4856263)
forum topics have disappeared again

jim is tinkering!!
   10. JimMusComp likes Billy Eppler.... Posted: December 07, 2014 at 06:43 PM (#4856285)
I couldn't comment on an article the other day - the Astro's coaches article.

Why I wanted to say something there is another story.
   11. Harveys Wallbangers Posted: December 07, 2014 at 07:10 PM (#4856295)
still no forum optics
   12. Harveys Wallbangers Posted: December 07, 2014 at 07:14 PM (#4856297)
forums back but cannot access
   13. Bote Man Posted: December 07, 2014 at 07:33 PM (#4856309)
I'm pretty sure I saw the BTF server on a truck in the N.C. Welcome Center on I-95.
   14. Jim Furtado Posted: December 07, 2014 at 07:49 PM (#4856321)
The forum issue should be fixed.
   15. Jim Furtado Posted: December 07, 2014 at 07:55 PM (#4856323)
There are still some bugs that haven't been fixed with the underlying Expression Engine code. I will have to go through my notes to re-fix the issue with commenting on some articles. For now I'm going through the posted articles and manually fixing the entries.
   16. Just drawing conclusions on the wall Posted: December 07, 2014 at 08:11 PM (#4856333)
I tried to comment on the post of the Tracy Ringsby? article about old time winter meetings. It did not work-I thought it was because I had turned of Javascript (which I have to do to use this site) but when I turned it back on it still would not take a comment.
   17. Bote Man Posted: December 07, 2014 at 08:26 PM (#4856344)
#16 - Not sure why you'd have to turn off JavaScript, but if you're running Firefox I highly recommend the NoScript plugin. You can simply leave this site off its whitelist.

You will have to add other sites that you visit regularly and trust, but any nasty sites won't be able to run bad stuff; with practice you can also save some bandwidth and cpu cycles by excluding tracking and advertising aggregators.
   18. Sheer Tim Foli Posted: December 07, 2014 at 08:29 PM (#4856346)
Alas the forums are still missing for me.
   19. Jim Furtado Posted: December 07, 2014 at 08:30 PM (#4856347)
I've rehacked the EE code to get rid of the problem preventing comments on some entries.
   20. Mark S. is bored Posted: December 07, 2014 at 09:48 PM (#4856375)
Alas the forums are still missing for me.


Log out and log back in. Remember to log out with your left hand and log in with your right hand while facing a southwesterly direction.
   21. Greg Pope Posted: December 07, 2014 at 10:06 PM (#4856380)
Jim, have you tested on an iPad? The ads are really annoying. I'm not sure if I can describe them well enough, but I could send some screen shots.

Basically, there are the standard ads, which behave like they do on the PC (and are fine). But there is some sort of banner ad that shows up at the bottom. It stays at the bottom of the screen, covering up the content. When you scroll, it stays in the same place on the page until you finish scrolling, then resets to the bottom. So if it was covering up comment 2, then when you scroll it stays over comment 2 until you're done scrolling. Then goes back to the bottom.

Since the banner is over everything, it covers up content, which makes it difficult. I pretty much have to close the add with the X on every page. And even that is hard because some of the X's are really far over to the right, and they're small. Plus, if I'm zoomed in, I have to scroll to even see the X.
   22. davekemp Posted: December 07, 2014 at 10:30 PM (#4856389)
Beta site now says the following when I click to see the comments on any article:

Error

Something has gone wrong and this URL cannot be processed at this time.


I love the beta site! Hope it survives the upgrade. It's a godsend for mobile readers like me.
   23. Jim Furtado Posted: December 07, 2014 at 11:22 PM (#4856410)
EE changed the way conditionals are handled. I still need to fix some code. When that's done I'm redoing a few things on the beta and adding some sidebar content before changing the site over to that design. I hope to have the beta working in the next week. I'm taking some vacation time in January and February to get the rest of the stuff done. Free time, unfortunately, is still in short supply.

Greg, I will take a look on my wife's iPad. Ad stuff is often tough to sort out because different ads get served to different users.
   24. davekemp Posted: December 07, 2014 at 11:45 PM (#4856432)
Thanks Jim for the update and of course the effort
   25. Cooper Nielson Posted: December 08, 2014 at 06:39 AM (#4856462)
Thanks for this. I don't mind advertising in general, but most of the ads I was seeing were pictures of well-muscled, half-naked men, which isn't really what I want people seeing on my screen at work.
   26. Jim Furtado Posted: December 08, 2014 at 01:47 PM (#4856717)
Andy, comment preview is fixed.
   27. Sheer Tim Foli Posted: December 08, 2014 at 07:13 PM (#4857039)
The forums work great on the PC now that i have logged out and back - but the iPad still makes them all disappear once I log in. Is anyone else experiencing this?
   28. Jim Furtado Posted: December 08, 2014 at 08:50 PM (#4857101)
Foli, try clearing your site cookies on the iPad.
   29. Greg Pope Posted: December 08, 2014 at 09:47 PM (#4857150)
Jim, I took some screen shots on my iPad. If you want to see them, let me know how to get them to you.
   30. Sheer Tim Foli Posted: December 08, 2014 at 09:58 PM (#4857156)
Thanks Jim.

Playing around I notice the Forum Home link goes nowhere but if I grab a link to a specific discussion it seems to work.
   31. SoSHially Unacceptable Posted: December 08, 2014 at 09:59 PM (#4857157)
Is the eternal edit button now gone?
   32. Sheer Tim Foli Posted: December 08, 2014 at 09:59 PM (#4857158)
Thanks Jim.

Playing around I notice the Forum Home link goes nowhere but if I grab a link to a specific discussion it seems to work.
   33. Spahn Insane Posted: December 08, 2014 at 11:41 PM (#4857216)
These newfangled "Obama's coming to steal your food" ads are comedy gold. I'd almost pay 20 bucks a year to •get• to read those.
   34. vortex of dissipation Posted: December 08, 2014 at 11:56 PM (#4857225)
These newfangled "Obama's coming to steal your food" ads are comedy gold. I'd almost pay 20 bucks a year to •get• to read those.


Actually, I wouldn't mind the ads if they were for some legitimate business, even if they were for things I'd never buy, such as diapers or pizza. But ads from whackos really disturb me...
   35. Jim Furtado Posted: December 09, 2014 at 08:28 AM (#4857287)
Foli, which Forum link?

SoSH, the edit link should time out after five minutes now.

Greg, I will send you an email.
   36. SoSHially Unacceptable Posted: December 09, 2014 at 10:23 AM (#4857400)
SoSH, the edit link should time out after five minutes now.


Five? That's way too quick. I'm glad the button now disappears when the edit option is closed, but I've gotten comfortable having the full 15.

   37. ERROR---Jolly Old St. Nick Posted: December 09, 2014 at 10:43 AM (#4857426)
Andy, comment preview is fixed.

I should have mentioned that the "Preview Your Comment" tab has been working since sometime yesterday, but this is the first time I've visited this thread since then. Thanks for correcting this, Jim.
   38. The District Attorney Posted: December 09, 2014 at 10:50 AM (#4857437)
Five? That's way too quick. I'm glad the button now disappears when the edit option is closed, but I've gotten comfortable having the full 15.
I was thinking 20 :)
   39. Bote Man Posted: December 09, 2014 at 11:13 AM (#4857468)
Put me down for 15 minutes of DOHHH! edit time. I've saved myself a good deal of embarrassment having 15 minutes to research and review some of the nonsense I've posted.
   40. Jim Furtado Posted: December 09, 2014 at 11:25 AM (#4857486)
Actually I misspoke. The comment editing is set to 15 minutes. Since EE has had problems with their code, let me know if that's not what you are seeing.
   41. SoSHially Unacceptable Posted: December 09, 2014 at 11:26 AM (#4857490)
Thanks Jim. I think we've all hurriedly attempted to fix our posts in that 0-15 minute mark while desperately hoping someone doesn't quote our idiocy into eternity.

   42. Sheer Tim Foli Posted: December 09, 2014 at 02:37 PM (#4857781)
Foli, which Forum link?


1) on my ipad
2) cleared all cookies and history
3) log in
4) can click a link inside the forums and see them fine
5) come to this very page and click "Forums" in the red bar and it goes to a blank page

   43. Greg Pope Posted: December 10, 2014 at 08:48 AM (#4858480)
Jim, did you get my e-mail?
   44. Jim Furtado Posted: December 10, 2014 at 09:26 AM (#4858514)
Yes, I haven't had time to check out the issue.
   45. Greg Pope Posted: December 10, 2014 at 09:28 AM (#4858520)
No problem. Just wanted to make sure it didn't get caught in a spam folder.
   46. Der-K: at 10% emotional investment Posted: January 07, 2015 at 10:38 AM (#4875033)
Lots of links are now broken.
Like this one for a list of the site's members: http://www.baseballthinkfactory.org/forums/member/memberlist
Clicking on the site's icon to get back to the main page from that page leads to this non-functioning URL: http://www.baseballthinkfactory.org/forums/member/{site_index}
...and so on and so forth when it comes to member lists and infrastructural type links. (Links to articles, comments, etc... seem to all be fine. Also, I'm working from the "old" interface, which likely has something to do with it.

Note: "{" should read: " % 7 B " and "}" is represented as " % 7 D ", sans spaces.
   47. Jim Furtado Posted: January 07, 2015 at 06:23 PM (#4875534)
Lots of links are now broken.
Thanks for the heads up. The recent update to Expression Engine has broken some stuff. For example, a few people have reported the reset password is not functioning. I'm fixing things as I find them and as I have time. A few issues will have to wait another couple of weeks (when I have some off-time scheduled from my day job to work on the site). In that week I'll be squishing these bugs, restructuring some old content, and trying to finish off as much of the redesign as I can. I'll write up a dedicated post on the topic when I have some time.
   48. The Ghost of Sox Fans Past Posted: January 19, 2015 at 01:44 PM (#4883951)
Jim, thanks for a benefit for donors. Well worth the money. Gotta figure out if I donated last year. Thought I had, but that's just from memory.

Where does the turn-off option show up - on one's My Account page?
   49. Infinite Yost (Voxter) Posted: February 13, 2015 at 01:44 AM (#4897628)
Dunno if this is where this belongs, but a problem that had been solved appears to have been un-solved in the last day or two.

For a long time, I had this thing where I couldn't stay logged in. I took various suggestions about clearing cookies & so forth, but nothing really worked. I was reliably signed out about every two hours, maybe less.

A few weeks (months?) ago, that stopped happening. I would be logged out if I turned off my browser, but otherwise no. In the last 48 hours or so, it's started happening again, even more frequently. I get signed out every 30-60 minutes, it seems, sometimes less.

Any ideas what might be happening? I'm using Chrome, if that helps.
   50. Greg Pope Posted: February 13, 2015 at 09:49 AM (#4897699)
I'm having a strange problem, and it's definitely different than before. I can't highlight any text on the page when using IE. Normally I highlight text and either copy it, or just hit the quote button. But since the upgrade (I assume), I can't highlight any text at all on BBTF pages. I can highlight text on other sites using IE.
   51. Greg Pope Posted: February 19, 2015 at 09:24 AM (#4899965)
Follow up to this, I turned on IE compatibility mode, and I can now highlight.
   52. Randy Jones Posted: February 19, 2015 at 09:41 AM (#4899980)
Follow up to this, I turned on IE compatibility mode, and I can now highlight.

Better solution, don't use IE.
   53. Fernigal McGunnigle Posted: February 19, 2015 at 11:33 AM (#4900046)
I just tried the page in IE (a fully updated IE 11, on 32-bit Windows 7) while not logged in and had no problems copying text. Then I logged in and could no longer highlight text with the mouse. Though I can click in the edit window and highlight everything with a ctrl-A, or click elsewhere and highlight the whole page. Copying from that works fine, it's just the highlighting that's the problem, and only when I'm logged in.

No issues with Chrome or Firefox.
   54. Greg Pope Posted: February 19, 2015 at 02:46 PM (#4900211)
Better solution, don't use IE.

Thanks, but I'll let Jim decide if he wants to support IE or not.
   55. Jose is an Absurd Force of Nature Posted: March 28, 2015 at 05:50 PM (#4919402)
Not sure where to put this but I am getting logged out a LOT. It happens on mobile devices (iPhone/iPads) with ridiculously regularity. I was at the Bruins game today and pretty much if I didn't post for ten minutes (especially in the lounge) I had to log back in. I am having similar issues on my MacBook Pro.

All my browsers/software are up to date. It's quite possible it's user error but wanted to pass it along.

You must be Registered and Logged In to post comments.

 

 

<< Back to main

BBTF Partner

Dynasty League Baseball

Support BBTF

donate

Thanks to
Adam M
for his generous support.

Bookmarks

You must be logged in to view your Bookmarks.

Syndicate

Page rendered in 0.3828 seconds
58 querie(s) executed